Back to overview
Degraded

GET /order missing tracking data

Sep 24 at 08:52am EDT
Affected services
PROD PBD API
Test PBD API

Resolved
Sep 24 at 09:31am EDT

Root cause:

An update was introduced to the backend data sync process for shipments on 09/23 around 15:00 ET. This was related to shipments with both primary and secondary tracking numbers (UPS Mail Innovations, UPS SurePost, etc)

This caused shipment headers to be synced to the integration database without issue, thus passing integration test cases.
However, shipment details (packages) were not properly synced.

Resolution:

The bug was corrected and the update redeployed. Backup sync process was kicked off to re-sync all affected shipments. All tracking is now available.

Additional integration test cases will be introduced to our sync service to account for the possibility of and prevent a partial sync of any record to our integration DB.

Updated
Sep 24 at 09:16am EDT

GET /order issue with missing tracking data only affects orders shipped after 3pm ET 09/24.

Fix scheduled for deployment within the hour.

Created
Sep 24 at 08:52am EDT

The shippedPackages array is currently reflecting an empty array. This should be resolved shortly.