Back to overview
Degraded
Production Order Submit Operation Currently Down
Jun 07 at 01:39pm EDT
Affected services
PROD PBD API
Resolved
Jun 07 at 01:45pm EDT
Production Order Submit Restored
Affected services
PROD PBD API
Created
Jun 07 at 01:39pm EDT
Order submit requests are currently failing. PBD investigating.
Affected services
PROD PBD API